Potential issue detected on our services

Incident
September 13, 2:44pm

Potential issue detected on our services

Status: closed
Start: September 13, 2:05pm
End: September 13, 2:44pm
Duration: 39 minutes
Affected Components:
Sherweb Hosted Services Microsoft Exchange Exchange 2019
Update

September 13, 2:05pm

September 13, 2:05pm

A possible issue affecting some Outlook services has been detected. Unable to reach or login to OWA.

Our system administrators are investigating to determine the cause and potential impact.

Please check back with this status page for developments regarding this issue.
Thank you for your patience. Our apologies for any inconvenience caused.

Best regards,
The Sherweb Technical Support Team

Resolved

September 13, 2:44pm

September 13, 2:44pm

The issue has been resolved.