Currency exchange rate issue

Incident
May 22, 10:44am

Currency exchange rate issue

Status: closed
Start: May 19, 10:59am
End: May 22, 10:44am
Duration: 2 days 23 hours 44 minutes
Affected Components:
External Marketplace Services QuickBooks Online Canada
Investigating

May 19, 10:59am

May 19, 10:59am

Some customers are currently unable to retrieve currency exchange rates when creating an invoice or paying bills. We’ve identified the source of the problem and are working to resolve the issue.

Resolved

May 22, 10:44am

May 22, 10:44am

This incident has been resolved.