Cumulus: Billing issue for end of April 2023

Informational
May 18, 10:21am

Cumulus: Billing issue for end of April 2023

Status: closed
Date: May 02, 11:20am
Affected Components:
Sherweb Hosted Services Cumulus Portal General
Update

May 02, 11:20am

May 02, 11:20am

We’re currently experiencing an issue with billing for the end of April 2023. Some customers may have received a partial or incorrect invoice, or no invoice at all. 

Our system administrators are working to resolve the issue as soon as possible. 

Please check back with this status page for developments regarding this issue.
Thank you for your patience. Our apologies for any inconvenience caused.

Best regards,
The Sherweb Technical Support Team

Resolved

May 18, 10:21am

May 18, 10:21am

General services are now working normally again. All issues have been resolved.