Unable to receive emails from Cumulus

Informational
November 30, 8:20pm

Unable to receive emails from Cumulus

Status: closed
Date: November 23, 2:55pm
Affected Components:
Hosted Services Cumulus Portal General
Investigating

November 23, 2:55pm

November 23, 2:55pm

A possible issue affecting General services has been detected. Symptoms include:  some clients are unable to receive emails from Cumulus as they are blocked by the receiving server due to MX validation.

Our system administrators are investigating to determine the cause and potential impact.

Please check back with this status page for developments regarding this issue.
Thank you for your patience. Our apologies for any inconvenience caused.

Best regards,
The Sherweb Technical Support Team

Resolved

November 30, 8:20pm

November 30, 8:20pm

General services are now working normally again. All issues have been resolved and we will keep monitoring the situation closely. Thank you.